[Résolu] Moteur par défaut Barre URL de Firefox

septembre 2018 modifié dans Technique

Hello, petit coucou à tous ! Je continue de suivre le forum et le blog même si je n'ai pas le temps de commenter souvent.

Je viens voir si d'autres personnes ici rencontrent le même bug que moi (voir si c'est reproductible ou si c'est dû à une erreur de config de ma part).
Voilà, depuis quelques versions de Firefox (actuellement 62.0.2 sous Manjaro), j'avais le moteur de recherche Qwant par défaut (pour la recherche via la barre d'url), configuré avec un user.js indiquant la ligne browser.urlbar.placeholderName "Qwant"
Sauf que désormais, à chaque redémarrage, il me remet par défaut le premier moteur de la liste par défaut de Firefox (c'est à dire Google. Si je supprime Google, ce sera Bing,... etc. Et si je les supprime tous sauf Qwant, ben il ne me proposera aucun moteur pour via la barre d'URL).

Il faut que j'aille dans les options et que je rechange moi-même le moteur par défaut pour que ce soit pris en compte.

Rencontrez-vous le même problème ?

Procédure plus claire si mon explication était obscure :
- Ouvrez Firefox
- Ajoutez un moteur de recherche personnalisé qui ne fasse pas partie de la liste par défaut (Qwant, Searx, Framabee, ...)
- Normalement, en tapant des mots dans la barre d'URL, Firefox effectue une recherche via ce moteur
- Fermez Firefox, relancez-le
- Firefox a remis par défaut Google (ou un autre moteur) lorsque vous tapez dans la barre d'URL.

à noter que je purge l'historique, cookies, le cache, les données de site web hors connexion lors de la fermture de firefox (mais pas les préférences de site).

Réponses

  • septembre 2018 modifié

    Bonsoir,
    Pas de problème avec ma machine personnelle (62.0 sous Ubuntu 18.04).
    Mais au boulot, la page d'accueil et d'autres préférences, sont réinitialisées par le fichier autoconfig.js ou mozilla.cfg, je n'en suis pas sûr on est dimanche, donc pas au boulot, fourni aimablement par nos administrateurs, qui est écrasé à chaque démarrage de la machine.

  • Il s'agit de mon ordi perso, donc pas de autoconfig.js ni de mozilla.cfg.
    J'ai supprimé le moteur Qwant pour tenter de le remettre ensuite (en pensant qu'il s'agissant d'une version obsolète suite au passage à 62).
    Mais plus moyen de le remettre ! Firefox ne propose plus l'option via la petite loupe pour ajouter un moteur directement depuis sa page. Et dans les modules non plus !
    Il y a bien des extensions Qwant mais elles ajoutent d'autres fonctionnalités. Je voulais juste le moteur basique. Même l'extension Qwant Basic ne marche pas : c'est Google qui reste le moteur par défaut. J'ai vérifié mes autres extensions, ça ne vient pas de ça.

  • Tu peux tenter d'aller dans about:support et de faire un "refresh" de FF (le bouton en haut à droite).
    C'est un peu comme sur IE, ça te remet les paramètres par défaut, donc ça vire aussi toutes les extensions, mais pour le reste, ton profil ne bouge pas.
    À utiliser en connaissance de cause, donc, mais perso ça m'a déjà été utile.

  • septembre 2018 modifié

    Ok donc accrochez vous bien
    (même si un blog, ça ne bouge pas)

  • Je n'ai pas restauré le profil. En revanche, comme je l'avais écris précédemment, j'ai supprimé le moteur Qwant de ma liste (que j'avais ajouté il y a longtemps) et je ne trouvais plus moyen de le remettre.

    Je n'ai pas restauré mon profil. J'ai juste cliqué sur "Restaurer les moteurs de recherche", et ça m'a ajouté Qwant parmi la liste (Qwant fait donc partie des moteurs de recherche livrés avec Firefox maintenant ?) et ... il marche parfaitement dans la barre d'URL.

    Il a dû y avoir un bug entre le moteur que j'avais ajouté par moi-même (d'une époque où Qwant n'était pas encore dans Firefox) et le moteur qui a été ajouté à la liste par défaut de Firefox.

    Petite ombre au tableau chez Qwant : il y a maintenant des liens sponsoriés microsofts en haut des résultats (sûrement provenant de Bing, Qwant doivent prélever une commission au passage)

Connectez-vous ou Inscrivez-vous pour répondre.