Thunderbird 60 et LaTeX It!

Bonjour,

Suite à la mise à jour de Thunderbird sous Debian, cette extension LaTeX It!, qui permet de taper du LaTeX dans un mail, ne fonctionne plus car il est incompatible avec cette version 60.0 de Thunderbird.

Y aurait-il un moyen de le forcer ou non ? ou existe-il un équivalent compatible avec cette version.

Pour l'instant, je n'ai rien trouvé. Peut être que l'un des collègues matheux aurait une solution...

Page de cette extension : https://addons.thunderbird.net/en-US/thunderbird/addon/latex-it/

Réponses

  • à part @Arnaud et @Alain je vois pas.

  • Bonjour,
    en attendant une maj du module (si un jour elle sera réalisée) vous pouvez :
    1/ essayer de forcer en modifiant le n° de version max dans le xpi du module
    2/ revenir à la version 5x.y.z de Thunderbird
    Les deux manip sont faciles à réaliser.

  • Il me semble qu'il y avait un truc qui fallait passer de false à true dans about:config pour que thunderbird accepte les extensions pour les versions antérieures.

  • Bon, en fait c'est inverse → https://www.ghacks.net/2018/04/24/thunderbird-60-and-extensions-support/
    Je viens d'essayer avec Firetray qui figure bien dans la liste des modules...mais dont je ne vois pas l’icône de notification.
    Je suis passé récemment à Mate et je ne sais pas si c'est du côté de la zone de notification ou celui du module (dont la version supportée s'arrête à 50)

  • Je n'utilise pas Thunderbird.

  • Bonjour,

    @CitronDoux a dit :
    Bonjour,
    en attendant une maj du module (si un jour elle sera réalisée) vous pouvez :
    1/ essayer de forcer en modifiant le n° de version max dans le xpi du module

    Ca ne veut pas car j'ai le message qu'il est frauduleux.
    Comment j'ai procédé

    • J'ai renommé le xpi en zip
    • J'ai édité le fichier install.rdf et changer le numéro max de version
    • Je sauvegarde
    • Je compresse en zip puis renomme en xpi.

    @CitronDoux a dit :
    2/ revenir à la version 5x.y.z de Thunderbird

    Si je pouvais éviter.

    Ceci fonctionne et donc j'ai bien cette extension sans le message d'erreur de compatibilité.
    Mais je n'arrive pas à configurer pour sauvegarder les chemins pour la compilation LaTeX et l'autodetection de ces chemins ne se fait pas.

    A suivre

  • @xavier a dit :
    Bonjour,

    @CitronDoux a dit :
    Bonjour,
    en attendant une maj du module (si un jour elle sera réalisée) vous pouvez :
    1/ essayer de forcer en modifiant le n° de version max dans le xpi du module

    Ca ne veut pas car j'ai le message qu'il est frauduleux.
    Comment j'ai procédé

    • J'ai renommé le xpi en zip
    • J'ai édité le fichier install.rdf et changer le numéro max de version
    • Je sauvegarde
    • Je compresse en zip puis renomme en xpi.

    Alors je ne sais pas du tout de quoi il s'agit, mais je sais que par exemple sur Android, le format de compression utilisé n'est pas un simple zip, et, pour modifier un fichier de flash, à défaut de savoir quelle compression utiliser/comment conserver la signature (j'ignore quel est exactement le problème), on peut ouvrir le fichier avec un gestionnaire d'archives et modifier les fichiers depuis ce dernier, sans jamais décompresser/recompresser. Cela permet de garder intacte la structure de l'archive, qui passe ensuite les contrôles.
    J'ignore si cela fonctionnerait ici, mais ça vaut peut-être le coup d'essayer ?

Connectez-vous ou Inscrivez-vous pour répondre.